Is there any backward compatibility supported for products in the V-Ray Collection?

The V-Ray Collection license enables products of V-Ray 5 and earlier, although it’s recommended to use at least V-Ray Next.